Service Desk Ticket Issues
Incident Report for NTES IT Support
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 12:02 GMT
Investigating
We are currently experiencing an issue with our service ticketing system. Because of this, engineers are working on email and phone only at this time. For urgent issues, please call +353 818 NTESIT
Posted Mar 16, 2023 - 09:35 GMT
This incident affected: General Issue / Service Desk.