Mail Flow Issues
Incident Report for NTES IT Support
Resolved
Temporary routing issue with Microsoft 365 - Resolved.
Posted Oct 20, 2022 - 11:58 IST
Investigating
We are currently investigating reports of email flow issues to our support team, and other sections of the business. For urgent issues please call +353 1 9011234.
Posted Oct 20, 2022 - 11:36 IST
This incident affected: General Issue / Service Desk.