Power Outage in Castletroy / Affecting Services
Incident Report for NTES IT Support
Resolved
Issue is resolved, power is restored.
Posted Jun 26, 2023 - 11:09 IST
Monitoring
Notice Only: We currently have a power failure in our office location. We are continuing to function on our support desk via backup, but with some limitations on service.
Posted Jun 26, 2023 - 09:37 IST
This incident affected: General Issue / Service Desk.